Ubuntu 更新glibc

xingyun86 28天前 40

使用sudo apt-get install glibc没有成功。

使用sudo apt-get upgrade glibc成功升级。

===============================================

Glib被用到很多开源库中,但不知啥原因,Glib的安装并没有被整合到Ubuntu的安装源,需要自己安装。

首先下载、解压最新的版本,安装:

wget http://ftp.acc.umu.se/pub/GNOME/sources/glib/2.45/glib-2.45.2.tar.xz
tar -vxf glib-2.45.2.tar.xz
cd glib-2.45.2.tar.xz
./configure
make 
sudo make install

如果出现libffi找不到的提示,则安装之:

sudo apt-get install libffi-dev

然后再次执行:

./configure
make 
sudo make install

OK,搞定。

×
打赏作者
最新回复 (0)
只看楼主
全部楼主
返回